Print
Hits: 1721

Just posting this here, as the information wasn't really readily available when I did this.  Most of the newer and popular Joomla extensions require PHP 5.4 or better.  Since 5.4 is a dead branch, updates wise, I moved to 5.6.

 

Steps (Use sudo only if required)

1) Remove OLD Apache

sudo service httpd stop
sudo yum erase httpd httpd-tools apr apr-util

2) Remove OLD PHP

sudo yum remove php-*

3) Install PHP 5.6 (Apache 2.4 will be automatically installed with this)

sudo yum install php56

4) Make sure all the required PHP extensions are installed

yum list installed | grep php

5) If not then install them using

sudo yum install php56-xml php56-xmlrpc php56-soap php56-gd

6) To list the other available php extensions

yum search php56

7) PHP 5.6 MySQL extension (Assume you have already installed MySQL)

sudo yum install php56-mysqlnd 

(NOTE: it is not php56-mysql)

8) Start / Restart Apache

sudo service httpd start
sudo service httpd restart

9) Check the version

php -v
httpd -v